ixp4xx/fsg3: Fix board code detection of the RTC chip
[openwrt/svn-archive/archive.git] / target / linux / rdc / Makefile
index 8c948239d4cce6bfcc8e109a351eef7bec770022..86265c38a1a01751408ec6a43b7c6459af8152ca 100644 (file)
@@ -9,27 +9,15 @@ include $(TOPDIR)/rules.mk
 ARCH:=i386
 BOARD:=rdc
 BOARDNAME:=RDC 321x
-FEATURES:=squashfs jffs2 pci
+FEATURES:=squashfs jffs2 pci usb
 
-LINUX_VERSION:=2.6.25.7
+LINUX_VERSION:=2.6.24.7
 
 include $(INCLUDE_DIR)/target.mk
 
 define Target/Description
         Build firmware images for RDC321x based routers
-        (e.g. Airlink101 AR525W, Linksys WRT54R, Sitecom WL-153)
+        (e.g. Airlink101 AR525W, Linksys WRT54GR, Sitecom WL-153)
 endef
 
-ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
-  define Kernel/SetInitramfs
-       echo "r6040 parent=wlan0" > $(TARGET_DIR)/etc/modules.d/99-r6040
-       $(RM) $(TARGET_DIR)/sbin/init
-       ln -s /etc/preinit $(TARGET_DIR)/sbin/init
-       sed -i 's,exec /sbin/init,exec /bin/busybox init,g' $(TARGET_DIR)/etc/preinit
-       sed -i 's,/sbin/init,/bin/busybox init,g' $(TARGET_DIR)/init
-       mv $(TARGET_DIR)/init $(TARGET_DIR)/linuxrc
-       sed -i 's,eth0,eth1,g' $(TARGET_DIR)/etc/config/network
-  endef
-endif
-
 $(eval $(call BuildTarget))