realtek: remove support for HPE 1920 series
[openwrt/staging/jow.git] / target / linux / realtek / image / rtl838x.mk
index f38e4977d2aaff211a0fcad88d8661bdcb1bdfd8..887f82e385c410bbaf3cb2c3c0d474fbb833f3ac 100644 (file)
@@ -15,6 +15,16 @@ define Device/d-link_dgs-1210
   SOC := rtl8382
   IMAGE_SIZE := 13824k
   DEVICE_VENDOR := D-Link
+  DLINK_KERNEL_PART_SIZE := 1572864
+  KERNEL := kernel-bin | append-dtb | gzip | uImage gzip | dlink-cameo
+  CAMEO_KERNEL_PART := 2
+  CAMEO_ROOTFS_PART := 3
+  CAMEO_CUSTOMER_SIGNATURE := 2
+  CAMEO_BOARD_VERSION := 32
+  IMAGES += factory_image1.bin
+  IMAGE/factory_image1.bin := append-kernel | pad-to 64k | \
+       append-rootfs | pad-rootfs | pad-to 16 | check-size | \
+       dlink-version | dlink-headers
 endef
 
 define Device/d-link_dgs-1210-10p