ath79: convert Netgear EX7300 caldata to nvmem
[openwrt/staging/nbd.git] / target / linux / realtek / patches-5.10 / 312-rt9313-support.patch
index 37a61106d20b12ae5c3b164dd8d968220c38d142..7626cc9c25c3cb887bd31a271ef59eb3b0fe5615 100644 (file)
@@ -1,3 +1,19 @@
+From 0b8dfe085180b58b81d2657c76b080168e3bc8df Mon Sep 17 00:00:00 2001
+From: Birger Koblitz <git@birger-koblitz.de>
+Date: Wed, 19 Jan 2022 18:14:02 +0100
+Subject: [PATCH] realtek: Add RTL931X sub-target
+
+We add the RTL931X sub-target with kernel configuration for
+a dual core MIPS InterAptive CPU.
+
+Submitted-by: Sebastian Gottschall <s.gottschall@dd-wrt.com>
+Submitted-by: Birger Koblitz <git@birger-koblitz.de>
+---
+ arch/mips/Makefile                            | 10 +++++++++++++--
+ arch/mips/kernel/head.S                       |  4 ++++
+ aarch/mips/kernel/vmlinux.lds.S               |  4 ++++
+ 3 files changed, 18 insertions(+), 2 deletions(-)
+
 --- a/arch/mips/Makefile
 +++ b/arch/mips/Makefile
 @@ -307,14 +307,24 @@ endif
  ifdef CONFIG_32BIT
  bootvars-y    += ADDR_BITS=32
  endif
---- a/arch/mips/kernel/head.S
-+++ b/arch/mips/kernel/head.S
-@@ -60,12 +60,14 @@
-       .endm
- #ifndef CONFIG_NO_EXCEPT_FILL
-+#ifndef CONFIG_RTL931X
-       /*
-        * Reserved space for exception handlers.
-        * Necessary for machines which link their kernels at KSEG0.
-        */
-       .fill   0x400
- #endif
-+#endif
- EXPORT(_stext)
-@@ -79,11 +81,13 @@ FEXPORT(__kernel_entry)
-       j       kernel_entry
- #endif /* CONFIG_BOOT_RAW */
-+#ifndef CONFIG_RTL931X
- #ifdef CONFIG_IMAGE_CMDLINE_HACK
-       .ascii  "CMDLINE:"
- EXPORT(__image_cmdline)
-       .fill   0x400
- #endif /* CONFIG_IMAGE_CMDLINE_HACK */
-+#endif
-       __REF
 --- a/arch/mips/kernel/vmlinux.lds.S
 +++ b/arch/mips/kernel/vmlinux.lds.S
 @@ -55,7 +55,11 @@ SECTIONS