realtek: refresh patches for Kernel 5.10
[openwrt/staging/noltari.git] / target / linux / realtek / patches-5.10 / 705-add-rtl-phy.patch
index c1b74f7fe4edf496644d938dd5befd63aea2ceff..dbd936b446941702c922e58f5e050570aa091da0 100644 (file)
@@ -1,7 +1,7 @@
 --- a/drivers/net/phy/Kconfig
 +++ b/drivers/net/phy/Kconfig
-@@ -540,6 +540,12 @@ config REALTEK_PHY
-       ---help---
+@@ -324,6 +324,12 @@ config REALTEK_PHY
+       help
          Supports the Realtek 821x PHY.
  
 +config REALTEK_SOC_PHY
 +        Supports the PHYs found in combination with Realtek Switch SoCs
 +
  config RENESAS_PHY
-       tristate "Driver for Renesas PHYs"
-       ---help---
+       tristate "Renesas PHYs"
+       help
 --- a/drivers/net/phy/Makefile
 +++ b/drivers/net/phy/Makefile
-@@ -102,6 +102,7 @@ obj-$(CONFIG_NATIONAL_PHY) += national.o
+@@ -86,6 +86,7 @@ obj-$(CONFIG_NATIONAL_PHY)   += national.o
  obj-$(CONFIG_NXP_TJA11XX_PHY) += nxp-tja11xx.o
  obj-$(CONFIG_QSEMI_PHY)               += qsemi.o
  obj-$(CONFIG_REALTEK_PHY)     += realtek.o