realtek: refresh patches in 5.15
[openwrt/staging/jow.git] / target / linux / realtek / patches-5.15 / 301-gpio-add-rtl8231-driver.patch
index 27256512438b0c147459b3045a0299d71ddd32ad..7603a037442445555820584567e54e54cb14528f 100644 (file)
@@ -25,9 +25,9 @@ Submitted-by: John Crispin <john@phrozen.org>
 
 --- a/drivers/gpio/Kconfig
 +++ b/drivers/gpio/Kconfig
-@@ -508,6 +508,12 @@ config GPIO_REG
-         A 32-bit single register GPIO fixed in/out implementation.  This
-         can be used to represent any register as a set of GPIO signals.
+@@ -529,6 +529,12 @@ config GPIO_ROCKCHIP
+       help
+         Say yes here to support GPIO on Rockchip SoCs.
  
 +config GPIO_RTL8231
 +      tristate "RTL8231 GPIO"
@@ -40,10 +40,10 @@ Submitted-by: John Crispin <john@phrozen.org>
        depends on MFD_SYSCON
 --- a/drivers/gpio/Makefile
 +++ b/drivers/gpio/Makefile
-@@ -127,6 +127,7 @@ obj-$(CONFIG_GPIO_RDA)                     += gpio-rda.o
- obj-$(CONFIG_GPIO_RDC321X)            += gpio-rdc321x.o
+@@ -129,6 +129,7 @@ obj-$(CONFIG_GPIO_RDC321X)         += gpio-rdc3
  obj-$(CONFIG_GPIO_REALTEK_OTTO)               += gpio-realtek-otto.o
  obj-$(CONFIG_GPIO_REG)                        += gpio-reg.o
+ obj-$(CONFIG_GPIO_ROCKCHIP)   += gpio-rockchip.o
 +obj-$(CONFIG_GPIO_RTL8231)            += gpio-rtl8231.o
  obj-$(CONFIG_ARCH_SA1100)             += gpio-sa1100.o
  obj-$(CONFIG_GPIO_SAMA5D2_PIOBU)      += gpio-sama5d2-piobu.o