bcm53xx: use uncompressed zImages
[openwrt/staging/chunkeey.git] / target / linux / realview / Makefile
index e758ea77eaa7a62be1f0877ab8215c8ff7990a84..c4f7a72e390f5c78d85c887d7adc9b8c6ed8f229 100644 (file)
@@ -9,11 +9,14 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=realview
 BOARDNAME:=ARM Ltd. Realview board (qemu)
-FEATURES:=fpu ramdisk
-CFLAGS:=-Os -pipe -march=armv6k -mtune=mpcore -mfloat-abi=softfp -mfpu=vfp -fno-caller-saves
+FEATURES:=ext4 fpu ramdisk
+CPU_TYPE:=mpcore
+CPU_SUBTYPE:=vfp
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.0.3
+KERNEL_PATCHVER:=4.4
+
+DEVICE_TYPE:=developerboard
 
 include $(INCLUDE_DIR)/target.mk
 
@@ -21,6 +24,6 @@ define Target/Description
        Build images for ARM Ltd. Realview boards to be run with qemu
 endef
 
-KERNELNAME:="zImage"
+KERNELNAME:=zImage
 
 $(eval $(call BuildTarget))