ramips: Don't trigger BUG_ON due to skb allocation failure
[openwrt/svn-archive/archive.git] / target / linux / s3c24xx / Makefile
index d6fc80a967c1bcd1f89605dce2df66b26f7ad660..0a051ff13738a7b103077e30dd3c50ff4cce647a 100644 (file)
@@ -1,4 +1,4 @@
-# 
+#
 # Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -8,15 +8,17 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=s3c24xx
-BOARDNAME:=s3c24xx
+BOARDNAME:=Samsung S3C24xx
 FEATURES:=jffs2
+CFLAGS:=-O2 -pipe -march=armv4t -mtune=arm920t -funit-at-a-time
+SUBTARGETS:=openmoko-gta02
 
-LINUX_VERSION:=2.6.28.2
+LINUX_VERSION:=2.6.30.10
 
 DEVICE_TYPE=phone
 
 define Target/Description
-       OpenMoko gta02
+       S3C24xx arm
 endef
 
 include $(INCLUDE_DIR)/target.mk