sunxi: Use rtl8723bu-firmware instead of rtl8723bs-firmware
[openwrt/staging/wigyori.git] / target / linux / sunxi / image / cortexa53.mk
index 117d25ea90077e06794280591241cc78c582d4c6..a00bac2c81c765c29ef9016f437f3d83c73e5a02 100644 (file)
@@ -9,13 +9,18 @@ define Device/sun50i
   KERNEL := kernel-bin
 endef
 
+define Device/sun50i-a64
+  SOC := sun50i-a64
+  $(Device/sun50i)
+endef
+
 define Device/sun50i-h5
   SOC := sun50i-h5
   $(Device/sun50i)
 endef
 
-define Device/sun50i-a64
-  SOC := sun50i-a64
+define Device/sun50i-h6
+  SOC := sun50i-h6
   $(Device/sun50i)
 endef
 
@@ -35,6 +40,15 @@ define Device/friendlyarm_nanopi-neo2
 endef
 TARGET_DEVICES += friendlyarm_nanopi-neo2
 
+define Device/friendlyarm_nanopi-r1s-h5
+  DEVICE_VENDOR := FriendlyARM
+  DEVICE_MODEL := Nanopi R1S H5
+  DEVICE_PACKAGES := kmod-gpio-button-hotplug kmod-usb-net-rtl8152
+  SUPPORTED_DEVICES:=nanopi-r1s-h5
+  $(Device/sun50i-h5)
+endef
+TARGET_DEVICES += friendlyarm_nanopi-r1s-h5
+
 define Device/libretech_all-h3-cc-h5
   DEVICE_VENDOR := Libre Computer
   DEVICE_MODEL := ALL-H3-CC
@@ -47,7 +61,7 @@ TARGET_DEVICES += libretech_all-h3-cc-h5
 define Device/olimex_a64-olinuxino
   DEVICE_VENDOR := Olimex
   DEVICE_MODEL := A64-Olinuxino
-  DEVICE_PACKAGES := kmod-rtl8723bs rtl8723bs-firmware
+  DEVICE_PACKAGES := kmod-rtl8723bs rtl8723bu-firmware
   $(Device/sun50i-a64)
   SUNXI_DTS := $$(SUNXI_DTS_DIR)$$(SOC)-olinuxino
 endef
@@ -57,7 +71,7 @@ define Device/olimex_a64-olinuxino-emmc
   DEVICE_VENDOR := Olimex
   DEVICE_MODEL := A64-Olinuxino
   DEVICE_VARIANT := eMMC
-  DEVICE_PACKAGES := kmod-rtl8723bs rtl8723bs-firmware
+  DEVICE_PACKAGES := kmod-rtl8723bs rtl8723bu-firmware
   $(Device/sun50i-a64)
   SUNXI_DTS := $$(SUNXI_DTS_DIR)$$(SOC)-olinuxino-emmc
 endef
@@ -66,6 +80,7 @@ TARGET_DEVICES += olimex_a64-olinuxino-emmc
 define Device/pine64_pine64-plus
   DEVICE_VENDOR := Pine64
   DEVICE_MODEL := Pine64+
+  DEVICE_PACKAGES := kmod-rtl8723bs rtl8723bu-firmware
   $(Device/sun50i-a64)
 endef
 TARGET_DEVICES += pine64_pine64-plus
@@ -73,10 +88,19 @@ TARGET_DEVICES += pine64_pine64-plus
 define Device/pine64_sopine-baseboard
   DEVICE_VENDOR := Pine64
   DEVICE_MODEL := SoPine
+  DEVICE_PACKAGES := kmod-rtl8723bs rtl8723bu-firmware
   $(Device/sun50i-a64)
 endef
 TARGET_DEVICES += pine64_sopine-baseboard
 
+define Device/xunlong_orangepi-one-plus
+  $(Device/sun50i-h6)
+  DEVICE_VENDOR := Xunlong
+  DEVICE_MODEL := Orange Pi One Plus
+  SUNXI_DTS_DIR := allwinner/
+endef
+TARGET_DEVICES += xunlong_orangepi-one-plus
+
 define Device/xunlong_orangepi-pc2
   DEVICE_VENDOR := Xunlong
   DEVICE_MODEL := Orange Pi PC 2