sunxi: add support for Retro Games Limited C=64 Mini (RGL001)
[openwrt/staging/wigyori.git] / target / linux / sunxi / image / cortexa7.mk
index 6d593e180dd551254a42324587221f6b20ef8094..375b5d413febebc027211962822be3d02a7e37fe 100644 (file)
@@ -138,6 +138,14 @@ define Device/sinovoip_bananapi-m2-plus
 endef
 TARGET_DEVICES += sinovoip_bananapi-m2-plus
 
+define Device/rgl_c64mini
+  DEVICE_VENDOR := Retro Games Limited
+  DEVICE_MODEL := C=64 Mini
+  DEVICE_PACKAGES:=kmod-rtc-sunxi kmod-leds-gpio
+  SOC := sun7i-a20
+endef
+TARGET_DEVICES += rgl_c64mini
+
 define Device/sinovoip_bananapi-m3
   DEVICE_VENDOR := Sinovoip
   DEVICE_MODEL := Banana Pi M3