Add profile and userspace for P2812HNUF1/3, switch from UBI_GLUEBI to UBI_BLOCK
[openwrt/svn-archive/archive.git] / target / linux / sunxi / modules.mk
index 9a4782ddf27464cb02defa9cd5c4a6aee51d7125..a4c71b9b8645886b3e63a6fd35aaca124c3d9bc7 100644 (file)
@@ -22,6 +22,26 @@ endef
 
 $(eval $(call KernelPackage,rtc-sunxi))
 
+define KernelPackage/sunxi-ir
+    SUBMENU:=$(OTHER_MENU)
+    TITLE:=Sunxi SoC built-in IR support (A20)
+    DEPENDS:=@TARGET_sunxi +kmod-input-core
+    $(call AddDepends/rtc)
+    KCONFIG:= \
+       CONFIG_MEDIA_SUPPORT=y \
+       CONFIG_MEDIA_RC_SUPPORT=y \
+       CONFIG_RC_DEVICES=y \
+       CONFIG_IR_SUNXI
+    FILES:=$(LINUX_DIR)/drivers/media/rc/sunxi-cir.ko
+    AUTOLOAD:=$(call AutoLoad,50,sunxi-cir)
+endef
+
+define KernelPackage/sunxi-ir/description
+ Support for the AllWinner sunXi SoC's onboard IR (A20)
+endef
+
+$(eval $(call KernelPackage,sunxi-ir))
+
 define KernelPackage/eeprom-sunxi
     SUBMENU:=$(OTHER_MENU)
     TITLE:=AllWinner Security ID fuse support
@@ -66,3 +86,19 @@ endef
 
 $(eval $(call KernelPackage,sun4i-emac))
 
+
+define KernelPackage/wdt-sunxi
+    SUBMENU:=$(OTHER_MENU)
+    TITLE:=AllWinner sunXi Watchdog timer
+    DEPENDS:=@TARGET_sunxi
+    KCONFIG:=CONFIG_SUNXI_WATCHDOG
+    FILES:=$(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/sunxi_wdt.ko
+    AUTOLOAD:=$(call AutoLoad,51,sunxi_wdt)
+endef
+
+define KernelPackage/wdt-sunxi/description
+    Kernel module for AllWinner sunXi watchdog timer.
+endef
+
+$(eval $(call KernelPackage,wdt-sunxi))
+