update to 2.6.28.6
[openwrt/staging/yousong.git] / target / linux / uml / Makefile
index a6be082d0b943d83c06dd8355d7cc492ddc2460c..ed2b5f45569ce02f608c303fe10033bbc1628620 100644 (file)
@@ -20,16 +20,15 @@ ARCH:=$(shell uname -m | sed \
 )
 BOARD:=uml
 BOARDNAME:=User Mode Linux
-FEATURES:=broken ext2
+FEATURES:=ext2
 LINUX_CONFIG:=$(CURDIR)/config/$(ARCH)
 
-LINUX_VERSION:=2.6.22.4
+LINUX_VERSION:=2.6.28.6
 
-include $(INCLUDE_DIR)/kernel-build.mk
+include $(INCLUDE_DIR)/target.mk
 
-# include the profiles
--include profiles/*.mk
+DEFAULT_PACKAGES += hostapd-mini kmod-mac80211-hwsim
 
 endif
 
-$(eval $(call BuildKernel))
+$(eval $(call BuildTarget))