x86: switch image generation to new code
[openwrt/staging/jow.git] / target / linux / x86 / Makefile
index 45bb8c7cac25a5f3565fbd0c36a893300bdcda02..045d043e4d850fa71eca0ade50051034ad507dea 100644 (file)
@@ -9,20 +9,20 @@ include $(TOPDIR)/rules.mk
 ARCH:=i386
 BOARD:=x86
 BOARDNAME:=x86
-FEATURES:=squashfs ext4 vdi vmdk pcmcia targz
-SUBTARGETS=generic xen_domu ep80579 geode kvm_guest 64
-MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
+FEATURES:=squashfs ext4 vdi vmdk pcmcia targz fpu boot-part rootfs-part
+SUBTARGETS:=generic legacy geode 64
 
-DEFAULT_PACKAGES += partx-utils
-
-KERNEL_PATCHVER:=4.4
+KERNEL_PATCHVER:=5.4
+KERNEL_TESTING_PATCHVER:=5.4
 
 KERNELNAME:=bzImage
 
 include $(INCLUDE_DIR)/target.mk
 
+DEFAULT_PACKAGES += partx-utils mkf2fs e2fsprogs
+
 $(eval $(call BuildTarget))
 
-$(eval $(call $(if $(CONFIG_TARGET_ROOTFS_ISO),RequireCommand,Ignore),mkisofs, \
+$(eval $(call $(if $(CONFIG_ISO_IMAGES),RequireCommand,Ignore),mkisofs, \
        Please install mkisofs. \
 ))