treewide: replace nbd@openwrt.org with nbd@nbd.name
[openwrt/staging/dedeckeh.git] / target / linux / x86 / Makefile
index 771fd191f9b001457ec545bc4dabcf51cc60c89f..2c42ecc2bec57737928a2a8c9f01f8cc5b4b008a 100644 (file)
@@ -1,23 +1,28 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 include $(TOPDIR)/rules.mk
 
-ARCH=i386
+ARCH:=i386
 BOARD:=x86
 BOARDNAME:=x86
-FEATURES:=squashfs jffs2 ext2
+FEATURES:=squashfs ext4 vdi vmdk pcmcia targz
+SUBTARGETS=generic legacy xen_domu geode 64
+MAINTAINER:=Felix Fietkau <nbd@nbd.name>
 
-LINUX_VERSION:=2.6.22.4
+DEFAULT_PACKAGES += partx-utils
 
-include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES += kmod-natsemi kmod-ne2k-pci
+KERNEL_PATCHVER:=4.4
 
-# include the profiles
--include profiles/*.mk
+KERNELNAME:=bzImage
+
+include $(INCLUDE_DIR)/target.mk
 
 $(eval $(call BuildTarget))
 
+$(eval $(call $(if $(CONFIG_TARGET_ROOTFS_ISO),RequireCommand,Ignore),mkisofs, \
+       Please install mkisofs. \
+))