update to the latest stable kernels
[openwrt/staging/dedeckeh.git] / target / linux / x86 / Makefile
index fc0db571268665d72125020e108c101d4d89527e..a3518af77899704d4e6ae2146314724919af7a21 100644 (file)
@@ -1,24 +1,23 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 include $(TOPDIR)/rules.mk
 
-ARCH=i386
+ARCH:=i386
 BOARD:=x86
 BOARDNAME:=x86
-FEATURES:=squashfs jffs2 ext2
+FEATURES:=squashfs jffs2 ext4 vdi vmdk pcmcia targz
+SUBTARGETS=generic olpc xen_domu ep80579 net5501 kvm_guest geos
 
-LINUX_VERSION:=2.6.22.4
+LINUX_VERSION:=2.6.32.26
 
 include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES += kmod-natsemi kmod-ne2k-pci
 
-$(eval $(call Target,generic))
-$(eval $(call Target,mediacenter))
 $(eval $(call BuildTarget))
+
 $(eval $(call $(if $(CONFIG_TARGET_ROOTFS_ISO),RequireCommand,Ignore),mkisofs, \
        Please install mkisofs. \
 ))