x86: switch image generation to new code
[openwrt/staging/jow.git] / target / linux / x86 / image / Makefile
index 9bd2eada6b43fd0083832ae3512e7809f62104f3..494a190b8664459655c0d4b7aad307278e46de9a 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2020 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
-export PATH=$(TARGET_PATH):/sbin
-BOOTOPTS=$(strip $(subst ",, $(CONFIG_X86_GRUB_BOOTOPTS)))
-ROOTPART=$(strip $(subst ",, $(CONFIG_X86_GRUB_ROOTPART)))
-#"))")) # fix vim's broken syntax highlighting
-
-
-ifeq ($(CONFIG_X86_GRUB_IMAGES),y)
-ifneq ($(HOST_OS),Darwin)
-  define Image/cmdline/squashfs
-    block2mtd.block2mtd=$(ROOTPART),65536,rootfs root=/dev/mtdblock0 rootfstype=squashfs init=/etc/preinit
-  endef
-
-  define Image/cmdline/jffs2-64k
-    block2mtd.block2mtd=$(ROOTPART),65536,rootfs root=/dev/mtdblock0 rootfstype=jffs2 init=/etc/preinit
-  endef
-
-  define Image/cmdline/jffs2-128k
-    block2mtd.block2mtd=$(ROOTPART),131072,rootfs root=/dev/mtdblock0 rootfstype=jffs2 init=/etc/preinit
-  endef
-
-  define Image/cmdline/ext2
-    root=$(ROOTPART) rootfstype=ext2 init=/etc/preinit
-  endef
-  
-  define Image/Build/grub
-       # left here because the image builder doesnt need these
-       $(INSTALL_DIR) $(KDIR)/root.grub/boot/grub
-       $(CP) \
-               $(KDIR)/*stage* \
-               $(KDIR)/root.grub/boot/grub/
-       $(CP) $(KDIR)/bzImage $(KDIR)/root.grub/boot/vmlinuz
-       sed \
-               -e 's#@CMDLINE@#$(strip $(call Image/cmdline/$(1))) $(BOOTOPTS)#g' \
-               -e 's#@BAUDRATE@#$(CONFIG_X86_GRUB_BAUDRATE)#g' \
-               ./menu.lst > $(KDIR)/root.grub/boot/grub/menu.lst
-       PADDING="$(CONFIG_X86_GRUB_IMAGES_PAD)" PATH="$(TARGET_PATH)" ./gen_image.sh $(BIN_DIR)/openwrt-$(BOARD)-$(1).image $(CONFIG_X86_GRUB_KERNELPART) $(KDIR)/root.grub $(CONFIG_TARGET_ROOTFS_FSPART) $(KDIR)/root.$(1)
-       $(call Image/Build/grub/$(1))
-  endef
-
-  define Image/Prepare/grub
-       # for the image builder
-       $(CP) \
-               $(STAGING_DIR_HOST)/usr/lib/grub/i386-pc/stage1 \
-               $(STAGING_DIR_HOST)/usr/lib/grub/i386-pc/stage2 \
-               $(STAGING_DIR_HOST)/usr/lib/grub/i386-pc/e2fs_stage1_5 \
-               $(KDIR)/
-  endef
+GRUB2_VARIANT =
+GRUB_TERMINALS =
+GRUB_SERIAL_CONFIG =
+GRUB_TERMINAL_CONFIG =
+GRUB_CONSOLE_CMDLINE =
+
+ifneq ($(strip $(foreach subtarget,$(USE_ATKBD),$(CONFIG_TARGET_x86_$(subtarget)))),)
+  GRUB2_VARIANT := generic
 else
-  define Image/Build/grub
-       PADDING="$(CONFIG_X86_GRUB_IMAGES_PAD)" PATH="$(TARGET_PATH)" NOGRUB=1 ./gen_image.sh $(BIN_DIR)/openwrt-$(BOARD)-$(1).image $(CONFIG_X86_GRUB_KERNELPART) "" $(CONFIG_TARGET_ROOTFS_FSPART) $(KDIR)/root.$(1)
-  endef
+  GRUB2_VARIANT := legacy
 endif
+
+ifneq ($(CONFIG_GRUB_CONSOLE),)
+  GRUB_CONSOLE_CMDLINE += console=tty0
+  GRUB_TERMINALS += console
 endif
 
-ifeq ($(CONFIG_X86_VDI_IMAGES),y)
-  define Image/Build/vdi
-    # left here because the image builder doesnt need these
-    ifeq ($(1),ext2)
-               rm $(BIN_DIR)/openwrt-$(BOARD)-ext2.vdi || true
-               vditool DD $(BIN_DIR)/openwrt-$(BOARD)-ext2.vdi $(BIN_DIR)/openwrt-$(BOARD)-ext2.image
-    endif
-  endef
+GRUB_SERIAL:=$(call qstrip,$(CONFIG_GRUB_SERIAL))
+
+ifneq ($(GRUB_SERIAL),)
+  GRUB_CONSOLE_CMDLINE += console=$(GRUB_SERIAL),$(CONFIG_GRUB_BAUDRATE)n8$(if $(CONFIG_GRUB_FLOWCONTROL),r,)
+  GRUB_SERIAL_CONFIG := serial --unit=0 --speed=$(CONFIG_GRUB_BAUDRATE) --word=8 --parity=no --stop=1 --rtscts=$(if $(CONFIG_GRUB_FLOWCONTROL),on,off)
+  GRUB_TERMINALS += serial
 endif
 
-ifeq ($(CONFIG_X86_VMDK_IMAGES),y)
-  define Image/Build/vmdk
-    # left here because the image builder doesnt need these
-    ifeq ($(1),ext2)
-               rm $(BIN_DIR)/openwrt-$(BOARD)-ext2.vmdk || true
-               qemu-img convert -f raw $(BIN_DIR)/openwrt-$(BOARD)-ext2.image \
-                       -O vmdk $(BIN_DIR)/openwrt-$(BOARD)-ext2.vmdk
-    endif
-  endef
+ifneq ($(GRUB_TERMINALS),)
+  GRUB_TERMINAL_CONFIG := terminal_input $(GRUB_TERMINALS); terminal_output $(GRUB_TERMINALS)
 endif
 
-define Image/Prepare
-       $(CP) $(LINUX_DIR)/arch/x86/boot/bzImage $(KDIR)/bzImage
-       $(call Image/Prepare/grub)
+ROOTPART:=$(call qstrip,$(CONFIG_TARGET_ROOTFS_PARTNAME))
+ROOTPART:=$(if $(ROOTPART),$(ROOTPART),PARTUUID=$(IMG_PART_SIGNATURE)-02)
+
+GRUB_TIMEOUT:=$(call qstrip,$(CONFIG_GRUB_TIMEOUT))
+GRUB_TITLE:=$(call qstrip,$(CONFIG_GRUB_TITLE))
+
+BOOTOPTS:=$(call qstrip,$(CONFIG_GRUB_BOOTOPTS))
+
+define Build/combined
+       $(CP) $(KDIR)/$(KERNEL_NAME) $@.boot/boot/vmlinuz
+       -$(CP) $(STAGING_DIR_ROOT)/boot/. $@.boot/boot/
+       PADDING="$(CONFIG_TARGET_IMAGES_PAD)" SIGNATURE="$(IMG_PART_SIGNATURE)" $(SCRIPT_DIR)/gen_image_generic.sh \
+               $@ \
+               $(CONFIG_TARGET_KERNEL_PARTSIZE) $@.boot \
+               $(CONFIG_TARGET_ROOTFS_PARTSIZE) $(IMAGE_ROOTFS) \
+               256
 endef
-  
-define Image/Build/squashfs
-    $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
+
+define Build/grub-config
+       rm -fR $@.boot
+       $(INSTALL_DIR) $@.boot/boot/grub
+       sed \
+               -e 's#@SERIAL_CONFIG@#$(strip $(GRUB_SERIAL_CONFIG))#g' \
+               -e 's#@TERMINAL_CONFIG@#$(strip $(GRUB_TERMINAL_CONFIG))#g' \
+               -e 's#@ROOTPART@#root=$(ROOTPART) rootwait#g' \
+               -e 's#@CMDLINE@#$(BOOTOPTS) $(GRUB_CONSOLE_CMDLINE)#g' \
+               -e 's#@TIMEOUT@#$(GRUB_TIMEOUT)#g' \
+               -e 's#@TITLE@#$(GRUB_TITLE)#g' \
+               ./grub-$(1).cfg > $@.boot/boot/grub/grub.cfg
 endef
 
-define Image/Build/iso 
-       $(CP) \
-               $(STAGING_DIR_HOST)/usr/lib/grub/i386-pc/stage2_eltorito \
-               $(KDIR)/root.grub/boot/grub/stage2_eltorito 
-       sed -i \
-               -e 's#@CMDLINE@#$(strip $(call Image/cmdline/$(1))) $(BOOTOPTS)#g' \
-               -e 's#@BAUDRATE@#$(CONFIG_X86_GRUB_BAUDRATE)#g' \
-               -e 's#(hd0,0)#(cd)#g' \
-                $(KDIR)/root.grub/boot/grub/menu.lst 
-       $(CP) $(KDIR)/bzImage $(KDIR)/root.grub/boot/vmlinuz 
-       mkisofs -R -b boot/grub/stage2_eltorito -no-emul-boot -boot-load-size 4 -boot-info-table \
-               -o $(KDIR)/root.iso $(KDIR)/root.grub 
-endef 
-
-define Image/BuildKernel
-       $(CP) $(KDIR)/bzImage $(BIN_DIR)/openwrt-$(BOARD)-vmlinuz
+define Build/grub-install
+       rm -fR $@.grub2
+       $(INSTALL_DIR) $@.grub2
+       $(CP) $(STAGING_DIR_HOST)/lib/grub/i386-pc/*.img \
+               $(STAGING_DIR_HOST)/lib/grub/grub2-$(GRUB2_VARIANT)/core.img \
+               $@.grub2/
+       echo '(hd0) $@' > $@.grub2/device.map
+       $(STAGING_DIR_HOST)/bin/grub-bios-setup \
+               -m "$@.grub2/device.map" \
+               -d "$@.grub2" \
+               -r "hd0,msdos1" \
+               $@
 endef
 
-define Image/Build
-       $(call Image/Build/$(1))
-       $(call Image/Build/grub,$(1))
-       $(call Image/Build/vdi,$(1))
-       $(call Image/Build/vmdk,$(1))
-       $(CP) $(KDIR)/root.$(1) $(BIN_DIR)/openwrt-$(BOARD)-$(1).fs
-       $(CP) $(KDIR)/bzImage $(BIN_DIR)/openwrt-$(BOARD)-vmlinuz
+define Build/iso
+       $(CP) $(KDIR)/$(KERNEL_NAME) $@.boot/boot/vmlinuz
+       cat \
+               $(STAGING_DIR_HOST)/lib/grub/i386-pc/cdboot.img \
+               $(STAGING_DIR_HOST)/lib/grub/grub2-iso/eltorito.img \
+               > $@.boot/boot/grub/eltorito.img
+       -$(CP) $(STAGING_DIR_ROOT)/boot/. $@.boot/boot/
+       mkisofs -R -b boot/grub/eltorito.img -no-emul-boot -boot-info-table \
+               -o $@ $@.boot $(TARGET_DIR)
 endef
 
-$(eval $(call BuildImage))
+define Build/vdi
+       qemu-img convert -f raw -O vdi $@ $@.new
+       @mv $@.new $@
+endef
+
+define Build/vmdk
+       qemu-img convert -f raw -O vmdk $@ $@.new
+       @mv $@.new $@
+endef
+
+DEVICE_VARS += GRUB2_VARIANT
+define Device/Default
+  ARTIFACT/image.iso := grub-config iso | iso
+  IMAGES := combined.img.gz
+  IMAGE/combined.img.gz := append-rootfs | pad-extra 128k | grub-config pc | combined | grub-install | gzip
+  IMAGE/combined.vdi := append-rootfs | pad-extra 128k | grub-config pc | combined | grub-install | vdi
+  IMAGE/combined.vmdk := append-rootfs | pad-extra 128k | grub-config pc | combined | grub-install | vmdk
+  KERNEL := kernel-bin
+  KERNEL_INSTALL := 1
+  KERNEL_NAME := bzImage
+  ifeq ($(CONFIG_ISO_IMAGES),y)
+    ARTIFACTS := image.iso
+  endif
+  ifeq ($(CONFIG_VDI_IMAGES),y)
+    IMAGES += combined.vdi
+  endif
+  ifeq ($(CONFIG_VMDK_IMAGES),y)
+    IMAGES += combined.vmdk
+  endif
+endef
+
+$(eval $(call Image/gzip-ext4-padded-squashfs))
 
-ifeq ($(CONFIG_X86_VDI_IMAGES),y)
-  $(eval $(call RequireCommand,vditool, \
-       You need vditool to generate VirtualBox images. \
-  ))
+ifeq ($(SUBTARGET),64)
+  include 64.mk
 endif
 
-ifeq ($(CONFIG_X86_VMDK_IMAGES),y)
-   $(eval $(call RequireCommand,qemu-img, \
-       You need qemu-img to generate VMware images. \
-   ))
+ifeq ($(SUBTARGET),generic)
+  include generic.mk
 endif
+
+ifeq ($(SUBTARGET),legacy)
+  include legacy.mk
+endif
+
+$(eval $(call BuildImage))
+