kernel: update linux 3.8 to 3.8.7
[openwrt/svn-archive/archive.git] / target / linux / x86 / modules.mk
index 2942b3a5f688f8ec27c13c3db5f2811e8822a8b9..f0d436c1e9017308d7c4ab8160ce0a8a72ba98dc 100644 (file)
@@ -246,3 +246,85 @@ endef
 
 $(eval $(call KernelPackage,wdt-scx200))
 
+I2C_SCX200_MODULES:=\
+  CONFIG_SCx200_I2C:drivers/i2c/busses/scx200_i2c
+
+define KernelPackage/i2c-scx200
+  $(call i2c_defaults,$(I2C_SCX200_MODULES),59)
+  TITLE:=Geode SCx200 I2C using GPIO pins
+  DEPENDS:=@PCI_SUPPORT @TARGET_x86 +kmod-i2c-algo-bit
+  KCONFIG+= \
+       CONFIG_SCx200_I2C_SCL=12 \
+       CONFIG_SCx200_I2C_SDA=13
+endef
+
+define KernelPackage/i2c-scx200/description
+ Kernel module for I2C using GPIO pins on the Geode SCx200 processors.
+endef
+
+$(eval $(call KernelPackage,i2c-scx200))
+
+
+I2C_SCX200_ACB_MODULES:=\
+  CONFIG_SCx200_ACB:drivers/i2c/busses/scx200_acb
+
+define KernelPackage/i2c-scx200-acb
+  $(call i2c_defaults,$(I2C_SCX200_ACB_MODULES),59)
+  TITLE:=Geode SCx200 ACCESS.bus support
+  DEPENDS:=@PCI_SUPPORT @TARGET_x86 +kmod-i2c-algo-bit
+endef
+
+define KernelPackage/i2c-scx200-acb/description
+ Kernel module for I2C using the ACCESS.bus controllers on the Geode SCx200
+ and SC1100 processors and the CS5535 and CS5536 Geode companion devices.
+endef
+
+$(eval $(call KernelPackage,i2c-scx200-acb))
+
+
+define KernelPackage/leds-wrap
+  SUBMENU:=$(LEDS_MENU)
+  TITLE:=PCengines WRAP LED support
+  DEPENDS:=@TARGET_x86 +kmod-gpio-scx200
+  KCONFIG:=CONFIG_LEDS_WRAP
+  FILES:=$(LINUX_DIR)/drivers/leds/leds-wrap.ko
+  AUTOLOAD:=$(call AutoLoad,50,leds-wrap)
+endef
+
+define KernelPackage/leds-wrap/description
+ Kernel module for PCengines WRAP LEDs
+endef
+
+$(eval $(call KernelPackage,leds-wrap))
+
+
+define KernelPackage/leds-net48xx
+  SUBMENU:=$(LEDS_MENU)
+  TITLE:=Soekris Net48xx LED support
+  DEPENDS:=@TARGET_x86 +kmod-gpio-scx200
+  KCONFIG:=CONFIG_LEDS_NET48XX
+  FILES:=$(LINUX_DIR)/drivers/leds/leds-net48xx.ko
+  AUTOLOAD:=$(call AutoLoad,50,leds-net48xx)
+endef
+
+define KernelPackage/leds-net48xx/description
+ Kernel module for Soekris Net48xx LEDs
+endef
+
+$(eval $(call KernelPackage,leds-net48xx))
+
+define KernelPackage/rdc321x-wdt
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=RDC321x watchdog
+  DEPENDS:=@TARGET_x86_rdc
+  KCONFIG:=CONFIG_RDC321X_WDT
+  FILES:=$(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/rdc321x_wdt.ko
+  AUTOLOAD:=$(call AutoLoad,50,rdc321x_wdt)
+endef
+
+define KernelPackage/rdc321x-wdt/description
+  RDC-321x watchdog driver
+endef
+
+$(eval $(call KernelPackage,rdc321x-wdt))
+