sdk: fix host menu config targets using ncurses
[openwrt/staging/noltari.git] / target / sdk / files / Makefile
index 01c1e1c788352af23ff65a2ae1e74ba8ec6f787c..2f89ce0cf85cd5ca5ff6e09579a1e630684046e1 100644 (file)
@@ -1,6 +1,6 @@
 # Makefile for OpenWrt
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -14,17 +14,8 @@ export TOPDIR LC_ALL LANG SDK
 
 world:
 
-# Initialize SDK snapshot
-.git/config:
-       @( \
-               echo -n "Initializing SDK ... "; \
-               git init -q .; \
-               find . -mindepth 1 -maxdepth 1 -not -name feeds | xargs git add; \
-               git commit -q -m "Initial state"; \
-               echo "ok."; \
-       )
-
-include $(TOPDIR)/include/host.mk
+DISTRO_PKG_CONFIG:=$(shell which -a pkg-config | grep -E '\/usr' | head -n 1)
+export PATH:=$(TOPDIR)/staging_dir/host/bin:$(PATH)
 
 ifneq ($(OPENWRT_BUILD),1)
   override OPENWRT_BUILD=1