toolchain: glibc: Increase min kernel version to 5.10
[openwrt/staging/nbd.git] / toolchain / glibc / common.mk
index d22098ea1165ceca6e30e4049749b96405a2ed01..107245472aac10945b3750b0314ce57aa3b1ab3a 100644 (file)
@@ -7,13 +7,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=glibc
-PKG_VERSION:=2.32
-PKG_RELEASE:=2
+PKG_VERSION:=2.35
+PKG_RELEASE:=1
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=0d9793e82a19bcef10ef7d73a26cd44b7ad30753
-PKG_MIRROR_HASH:=edb3e1f8792f3f10d6ade9ac35837e8b0b65ee12219f3580e1ac8ba363ef9e8f
+PKG_SOURCE_VERSION:=813a8d01716d4e099ec57194a93b14fa08b4beca
+PKG_MIRROR_HASH:=8c8d92dde334f0e0f9a0949d25b2950db513ce8723c31ae0b0ef64730a00322f
 PKG_SOURCE_URL:=https://sourceware.org/git/glibc.git
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.xz
 
@@ -63,7 +63,8 @@ GLIBC_CONFIGURE:= \
                --$(if $(CONFIG_SOFT_FLOAT),without,with)-fp \
                  $(if $(CONFIG_PKG_CC_STACKPROTECTOR_REGULAR),--enable-stack-protector=yes) \
                  $(if $(CONFIG_PKG_CC_STACKPROTECTOR_STRONG),--enable-stack-protector=strong) \
-               --enable-kernel=4.14.0
+                 $(if $(CONFIG_PKG_RELRO_FULL),--enable-bind-now) \
+               --enable-kernel=5.10.0
 
 export libc_cv_ssp=no
 export libc_cv_ssp_strong=no