glibc: update to latest 2.31 commit
[openwrt/staging/nbd.git] / toolchain / glibc / common.mk
index e26827664b869fd3ab4a6d77fe2bbb0c1c59e2c1..768ff19060948d3b65c663c111c68edfda55c4bb 100644 (file)
@@ -7,12 +7,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=glibc
-PKG_VERSION:=2.27
+PKG_VERSION:=2.31
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=77b4b8231e77702cfaceeac04f5a556f58573565
-PKG_MIRROR_HASH:=b5ec1cf3d63cbf1c20af07f3c289cb14a077ee9fcb2139047ac3ec80dd5194f9
+PKG_SOURCE_VERSION:=109474122400ca7d60782b131dc867a5c1f2fe55
+PKG_MIRROR_HASH:=5a04a24e69eace9eb892f0b48b869d31d4900ad656099064b6a9d8a342c13d8c
 PKG_SOURCE_URL:=https://sourceware.org/git/glibc.git
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.xz
 
@@ -60,7 +60,8 @@ GLIBC_CONFIGURE:= \
                --without-gd \
                --without-cvs \
                --enable-add-ons \
-               --$(if $(CONFIG_SOFT_FLOAT),without,with)-fp
+               --$(if $(CONFIG_SOFT_FLOAT),without,with)-fp \
+               --enable-kernel=4.14.0
 
 export libc_cv_ssp=no
 export libc_cv_ssp_strong=no