Remove existing old link before creating a new one
[openwrt/staging/wigyori.git] / toolchain / kernel-headers / Makefile
index 9427f82c7a81abde238d04093951e7270d813eef..fa7d349baadc7077543922b19c95abdbfa02b541 100644 (file)
@@ -57,19 +57,11 @@ ifneq ($(CONFIG_mips)$(CONFIG_mipsel),)
        $(CP) \
                $(HOST_BUILD_DIR)/arch/mips/include/asm/asm.h \
                $(HOST_BUILD_DIR)/arch/mips/include/asm/regdef.h \
+               $(HOST_BUILD_DIR)/arch/mips/include/asm/asm-eva.h \
                $(BUILD_DIR_TOOLCHAIN)/linux-dev/include/asm/
   endef
 endif
 
-define Host/Configure/post/cris
-       $(CP) \
-               $(HOST_BUILD_DIR)/include/linux/user.h \
-               $(BUILD_DIR_TOOLCHAIN)/linux-dev/include/linux/
-       ln -snf $(BUILD_DIR_TOOLCHAIN)/linux-dev/include/arch-v10/arch \
-               $(BUILD_DIR_TOOLCHAIN)/linux-dev/include/arch
-       $(SED) '/#include <asm\/page\.h>/d' $(BUILD_DIR_TOOLCHAIN)/linux-dev/include/asm/user.h
-endef
-
 define Host/Configure/post/mips
        $(call Host/Configure/lzma)
 endef
@@ -80,7 +72,8 @@ endef
 
 define Host/Prepare
        $(call Kernel/Prepare/Default)
-       ln -sf linux-$(LINUX_VERSION) $(BUILD_DIR_TOOLCHAIN)/linux
+       rm -f $(BUILD_DIR_TOOLCHAIN)/linux
+       ln -s linux-$(LINUX_VERSION) $(BUILD_DIR_TOOLCHAIN)/linux
        $(SED) 's/@expr length/@-expr length/' $(HOST_BUILD_DIR)/Makefile
 endef