disable autorebuild for the toolchain, as it can easily lead to build breakages
[openwrt/staging/yousong.git] / toolchain / uClibc / Makefile
index aecd15017f2fec79856c57e8f31df80d8f3c9b20..ccce335f39afefb93c590b9536e0f231f98fa870 100644 (file)
@@ -8,9 +8,9 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/target.mk
 
 PKG_NAME:=uClibc
-PKG_VERSION:=$(strip $(subst ",, $(CONFIG_UCLIBC_VERSION)))#"))
-PKG_EXTRAVERSION:=$(strip $(subst ",, $(CONFIG_UCLIBC_EXTRA_VERSION)))#"))
-PKG_VERSION_SNAPSHOT:=$(strip $(subst ",, $(CONFIG_UCLIBC_VERSION_SNAPSHOT)))#"))
+PKG_VERSION:=$(call qstrip,$(CONFIG_UCLIBC_VERSION))
+PKG_EXTRAVERSION:=$(call qstrip,$(CONFIG_UCLIBC_EXTRA_VERSION))
+PKG_VERSION_SNAPSHOT:=$(call qstrip,$(CONFIG_UCLIBC_VERSION_SNAPSHOT))
 ifeq ($(PKG_VERSION_SNAPSHOT),y)
 PKG_SOURCE_URL:=http://www.uclibc.org/downloads/snapshots
 else
@@ -43,6 +43,7 @@ PKG_CAT:=bzcat
 STAGING_DIR_HOST:=$(TOOLCHAIN_DIR)
 BUILD_DIR_HOST:=$(BUILD_DIR_TOOLCHAIN)
 PKG_BUILD_DIR:=$(BUILD_DIR_HOST)/uClibc-$(PKG_VERSION)$(PKG_EXTRAVERSION)
+override CONFIG_AUTOREBUILD=
 
 include $(INCLUDE_DIR)/host-build.mk
 
@@ -64,6 +65,13 @@ UCLIBC_TARGET_ARCH:=$(shell echo $(ARCH) | sed -e s'/-.*//' \
                -e 's/cris.*/cris/' \
 )
 
+# Remove me when there are no 2.6.23 targets
+ifeq ($(findstring 86,$(ARCH)),86)
+  ifneq ($(LINUX_2_6_23),y)
+       UCLIBC_TARGET_ARCH:=x86
+  endif
+endif
+
 define Build/Prepare/Snapshot
        $(PKG_UNPACK)
        rm -Rf $(PKG_BUILD_DIR)
@@ -90,7 +98,7 @@ ifeq ($(PKG_VERSION_SNAPSHOT),y)
 else
        $(call Build/Prepare/Default)
 endif
-       $(CP) ./$(CONFIG_DIR)/$(ARCH)$(if $(wildcard $(CONFIG_DIR)/$(ARCH).$(BOARD)),$(BOARD)) $(PKG_BUILD_DIR)/.config
+       $(CP) ./$(CONFIG_DIR)/$(ARCH)$(if $(wildcard $(CONFIG_DIR)/$(ARCH).$(BOARD)),.$(BOARD)) $(PKG_BUILD_DIR)/.config
 ifeq ($(PKG_VERSION),0.9.28)
        $(call Build/Prepare/V_0_9_28)
 endif
@@ -150,7 +158,7 @@ define Build/Compile
        $(SED) 's,UCLIBC_VERSION=.*,UCLIBC_VERSION=$(PKG_VERSION),' $(TOOLCHAIN_DIR)/info.mk
        $(SED) 's,UCLIBC_PATCHVER=.*,UCLIBC_PATCHVER=$(PKG_EXTRAVERSION),' $(TOOLCHAIN_DIR)/info.mk
        rm -rf $(TOOLCHAIN_DIR)/lib/libc.so
-       ln -s $(TOOLCHAIN_DIR)/lib/libc.so.0 $(TOOLCHAIN_DIR)/lib/libc.so
+       ln -s libc.so.0 $(TOOLCHAIN_DIR)/lib/libc.so
 endef
 
 define Build/Install