dnsmasq: rework network interface ignore
[openwrt/staging/jow.git] / tools / automake / Makefile
index 3a05cc90f8e306971f9c3e14a11d0b1d164f8dac..4c1e5758cbcbcea53e5dcb76d91990db611759f6 100644 (file)
@@ -8,11 +8,12 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=automake
 PKG_CPE_ID:=cpe:/a:gnu:automake
-PKG_VERSION:=1.15.1
+PKG_VERSION:=1.16.5
+PKG_API_VERSION:=$(word 2,$(subst ., ,$(PKG_VERSION)))
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@GNU/automake
-PKG_HASH:=af6ba39142220687c500f79b4aa2f181d9b24e4f8d8ec497cea4ba26c64bedaf
+PKG_HASH:=f01d58cd6d9d77fbdca9eb4bbd5ead1988228fdb73d6f7a201f5f8d6b118b469
 
 include $(INCLUDE_DIR)/host-build.mk
 
@@ -34,11 +35,13 @@ define Host/Install
        $(call Host/Compile/Default,install)
        mv $(STAGING_DIR_HOST)/bin/aclocal $(STAGING_DIR_HOST)/bin/aclocal.real
        $(INSTALL_BIN) ./files/aclocal $(STAGING_DIR_HOST)/bin
-       ln -sf aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.9
-       ln -sf aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.10
-       ln -sf aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.11
-       ln -sf aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.11.6
-       ln -sf aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.15
+       ( \
+               api=$(PKG_API_VERSION); \
+               while [ "$$$$api" -ge 11 ]; do \
+                       ln -sf aclocal "$(STAGING_DIR_HOST)/bin/aclocal-1.$$$$api"; \
+                       api=$$$$(($$$$api - 1)); \
+               done; \
+       )
 endef
 
 define Host/Uninstall