tools/coreutils: update to 9.2
[openwrt/staging/nbd.git] / tools / bc / Makefile
index 3d505d6032fa83315d33d9848a6f9f1630850ccf..2c29e094e23b2eacc7d3a8fb41c0043d77e538f1 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2013 OpenWrt.org
+# Copyright (C) 2013-2022 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,15 +7,19 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bc
-PKG_VERSION:=1.06.95
+PKG_VERSION:=1.07.1
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=http://alpha.gnu.org/gnu/bc \
-       http://gnualpha.uib.no/bc/ \
-       http://mirrors.fe.up.pt/pub/gnu-alpha/bc/ \
-       http://www.nic.funet.fi/pub/gnu/alpha/gnu/bc/
-PKG_HASH:=7ee4abbcfac03d8a6e1a8a3440558a3d239d6b858585063e745c760957725ecc
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@GNU/bc
+PKG_HASH:=62adfca89b0a1c0164c2cdca59ca210c1d44c3ffc46daf9931cf4942664cb02a
+
+PKG_FIXUP := autoreconf
+PKG_CPE_ID:=cpe:/a:gnu:bc
 
 include $(INCLUDE_DIR)/host-build.mk
 
+define Host/Uninstall
+       -$(call Host/Compile/Default,uninstall)
+endef
+
 $(eval $(call HostBuild))