tools/libressl: update to version 3.7.3
[openwrt/staging/jow.git] / tools / bison / Makefile
index bf7b92b2c12442ec9a64124299fa2b5ba8a47c47..0aa0969b20bc5e0cd91dd1850f718a31a0bb2fd1 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2008-2013 OpenWrt.org
+#
+# Copyright (C) 2008-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,22 +7,27 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bison
-PKG_VERSION:=3.0.2
+PKG_VERSION:=3.8.2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@GNU/$(PKG_NAME)
-PKG_MD5SUM:=146be9ff9fbd27497f0bf2286a5a2082
-PKG_CAT:=xzcat
+PKG_HASH:=9bba0214ccf7f1079c5d59210045227bcf619519840ebfa80cd3849cff5a5bf2
+PKG_CPE_ID:=cpe:/a:gnu:bison
 
 HOST_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/host-build.mk
 
-HOST_LDFLAGS += $(HOST_STATIC_LINKING)
+HOST_CONFIGURE_ARGS += --enable-threads=posix --disable-nls
+
+define Host/Install
+       $(call Host/Install/Default)
+       $(INSTALL_BIN) ./scripts/yacc $(STAGING_DIR_HOST)/bin/yacc
+endef
 
-define Host/Clean
-       -$(MAKE) -C $(HOST_BUILD_DIR) uninstall
-       $(call Host/Clean/Default)
+define Host/Uninstall
+       rm -f $(STAGING_DIR_HOST)/bin/yacc
+       -$(call Host/Compile/Default,uninstall)
 endef
 
 $(eval $(call HostBuild))