pkgconf: always retain -I and -L flags
[openwrt/staging/wigyori.git] / tools / ccache / Makefile
index e8e85b442afc04f39c6852d44e5e1112ea2d247e..4e9920787252810c485062b70e31768cedf421f8 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,42 +8,28 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/target.mk
 
 PKG_NAME:=ccache
-PKG_VERSION:=2.4
+PKG_VERSION:=3.7.7
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://samba.org/ftp/ccache/
-PKG_MD5SUM:=73c1ed1e767c1752dd0f548ec1e66ce7
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(TOOLCHAIN_BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_SOURCE_URL:=https://github.com/ccache/ccache/releases/download/v$(PKG_VERSION)
+PKG_HASH:=b7c1d6d6fe42f18e424de92746af863e0bc85794da3d69e44300840c478c98cd
 
 include $(INCLUDE_DIR)/host-build.mk
 
-ifneq ($(strip $(shell which ccache >/dev/null && echo found)),found)
-  define Build/Compile
-       $(MAKE) CC="$(HOSTCC)" -C $(PKG_BUILD_DIR)
-  endef
-
-  define Build/Install
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(STAGING_DIR)" \
-               install
-  endef
-
-  define Build/Clean
-       -$(MAKE) -C $(PKG_BUILD_DIR) uninstall
-       -$(MAKE) -C $(PKG_BUILD_DIR) clean
-       $(call Build/Clean/Default)
-  endef
-else
-  define Build/Prepare
-  endef
-  define Build/Configure
-  endef
-  define Build/Compile
-  endef
-  define Build/Clean
-  endef
-endif
+HOST_CONFIGURE_VARS += CC="$(HOSTCC_NOCACHE)"
+
+define Host/Install/ccache
+       $(INSTALL_DIR) $(STAGING_DIR_HOST)/bin/
+       $(CP) ./files/* $(STAGING_DIR_HOST)/bin/
+endef
+
+define Host/Clean
+       -$(MAKE) -C $(HOST_BUILD_DIR) uninstall
+       $(call Host/Clean/Default)
+endef
+define Host/Install
+       $(call Host/Install/Default)
+       $(call Host/Install/ccache)
+endef
 
 $(eval $(call HostBuild))