tools/expat: fix build error with ccache
[openwrt/staging/jow.git] / tools / ccache / Makefile
index 2a43a7e225a7d5576fd129227108a6e9f078f19a..5720dabf6ed6632f482d8d38ac853b6b3a56d99b 100644 (file)
@@ -1,55 +1,27 @@
-# 
-# Copyright (C) 2006-2012 OpenWrt.org
+#
+# Copyright (C) 2006-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 include $(TOPDIR)/rules.mk
-include $(INCLUDE_DIR)/target.mk
 
 PKG_NAME:=ccache
-PKG_VERSION:=3.1.7
+PKG_VERSION:=4.9.1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
-PKG_SOURCE_URL:=http://samba.org/ftp/ccache/
-PKG_MD5SUM:=80a698c22d0b06b19c88ac58e8d8b632
+PKG_SOURCE_URL:=https://github.com/ccache/ccache/releases/download/v$(PKG_VERSION)
+PKG_HASH:=4c03bc840699127d16c3f0e6112e3f40ce6a230d5873daa78c60a59c7ef59d25
 
 include $(INCLUDE_DIR)/host-build.mk
-
-HOSTCC:=$(HOSTCC_NOCACHE)
-
-define Host/Install/ccache
-       $(INSTALL_DIR) $(STAGING_DIR_HOST)/bin/
-       $(CP) ./files/* $(STAGING_DIR_HOST)/bin/
-endef
-
-ifneq ($(strip $(shell which ccache >/dev/null && echo found)),found)
-  define Host/Compile
-       $(MAKE) -C $(HOST_BUILD_DIR)
-  endef
-
-  define Host/Clean
-       -$(MAKE) -C $(HOST_BUILD_DIR) uninstall
-       $(call Host/Clean/Default)
-  endef
-  define Host/Install
-       $(call Host/Install/Default)
-       $(call Host/Install/ccache)
-  endef
-else
-  define Host/Prepare
-  endef
-  define Host/Configure
-  endef
-  define Host/Compile
-  endef
-  define Host/Install
-       $(call Host/Install/ccache)
-  endef
-  define Host/Clean
-  endef
-  define Download
-  endef
-endif
+include $(INCLUDE_DIR)/cmake.mk
+
+CMAKE_HOST_OPTIONS += \
+       -DCMAKE_C_COMPILER_LAUNCHER="" \
+       -DCMAKE_CXX_COMPILER_LAUNCHER="" \
+       -DCMAKE_SKIP_RPATH=FALSE \
+       -DCMAKE_INSTALL_RPATH="${STAGING_DIR_HOST}/lib" \
+       -DENABLE_DOCUMENTATION=OFF \
+       -DREDIS_STORAGE_BACKEND=OFF
 
 $(eval $(call HostBuild))