tools/coreutils: update to 9.3
[openwrt/staging/hauke.git] / tools / coreutils / Makefile
index 87c9102fa6219c6ba2d334c3289b0e354e7b4614..f799e83c5b62e26ba052aec42ed80306aa2c67ab 100644 (file)
@@ -8,11 +8,11 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=coreutils
 PKG_CPE_ID:=cpe:/a:gnu:coreutils
-PKG_VERSION:=8.32
+PKG_VERSION:=9.3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@GNU/coreutils
-PKG_HASH:=4458d8de7849df44ccab15e16b1548b285224dbba5f08fac070c1c0e0bcc4cfa
+PKG_HASH:=adbcfcfe899235b71e8768dcf07cd532520b7f54f9a8064843f8d199a904bbaa
 
 HOST_BUILD_PARALLEL := 1
 
@@ -35,4 +35,9 @@ define Host/Install
        ln -sf ginstall $(1)/bin/install
 endef
 
+define Host/Uninstall
+       rm -f $(STAGING_DIR_HOST)/bin/install
+       -$(call Host/Compile/Default,uninstall)
+endef
+
 $(eval $(call HostBuild))