tools/findutils: define list of installed programs
[openwrt/staging/nbd.git] / tools / findutils / Makefile
index b07c53d9f674e88fbac0d00b363e1b615125d2ac..fd0cde2145edea4d276c4bf7c727cc8335503578 100644 (file)
@@ -7,14 +7,31 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=findutils
-PKG_VERSION:=4.6.0
+PKG_CPE_ID:=cpe:/a:gnu:findutils
+PKG_VERSION:=4.9.0
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@GNU/$(PKG_NAME)
-PKG_HASH:=ded4c9f73731cd48fec3b6bdaccce896473b6d8e337e9612e16cf1431bb1169d
+PKG_HASH:=a2bfb8c09d436770edc59f50fa483e785b161a3b7b9d547573cb08065fd462fe
+
+PKG_PROGRAMS:=find locate updatedb xargs
 
 HOST_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/host-build.mk
 
+ifeq ($(HOST_OS),Darwin)
+       HOST_CFLAGS +=-D__nonnull\\(params\\)=
+endif
+
+HOST_CONFIGURE_ARGS += \
+       --enable-threads=pth \
+       --disable-rpath \
+       --disable-nls \
+       --without-selinux
+
+define Host/Uninstall
+       -$(call Host/Compile/Default,uninstall)
+endef
+
 $(eval $(call HostBuild))