tools/flex: fix PKG_CPE_ID
[openwrt/staging/pepe2k.git] / tools / flex / Makefile
index 8e32ace854e6c5cc500f4e59bea82b59d8281134..177136b78c77c31c56db2fc993d1273d3dd81562 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2008 OpenWrt.org
+#
+# Copyright (C) 2008-2016 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,19 +7,35 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=flex
-PKG_VERSION:=2.5.35
+PKG_CPE_ID:=cpe:/a:westes:flex
+PKG_VERSION:=2.6.4
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://github.com/westes/flex/releases/download/v$(PKG_VERSION)/
+PKG_HASH:=e87aae032bf07c26f85ac0ed3250998c37621d95f8bd748b31f15b33c45ee995
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=@SF/$(PKG_NAME)
-PKG_MD5SUM:=10714e50cea54dc7a227e3eddcd44d57
-PKG_CAT:=bzcat
+HOST_FIXUP:=autoreconf
+HOST_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/host-build.mk
 
-HOST_LDFLAGS += -static
+HOST_CONFIGURE_ARGS += --disable-shared
+
+define Host/Compile
+       $(call Host/Compile/Default,SUBDIRS='src tools')
+endef
+
+define Host/Install
+       $(call Host/Compile/Default,install SUBDIRS='src tools')
+       $(LN) flex $(STAGING_DIR_HOST)/bin/lex
+endef
+
+define Host/Uninstall
+       -$(call Host/Compile/Default,uninstall SUBDIRS='src tools')
+endef
 
 define Host/Clean
-       -$(MAKE) -C $(HOST_BUILD_DIR) uninstall
+       rm -f $(STAGING_DIR_HOST)/bin/lex
        $(call Host/Clean/Default)
 endef