treewide: clean up download hashes
[openwrt/staging/wigyori.git] / tools / flex / Makefile
index 8e32ace854e6c5cc500f4e59bea82b59d8281134..60ca240af696e9c4f31ce6a646bfd59d4989f17c 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2016 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,16 +7,17 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=flex
-PKG_VERSION:=2.5.35
+PKG_VERSION:=2.6.1
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=@SF/$(PKG_NAME)
-PKG_MD5SUM:=10714e50cea54dc7a227e3eddcd44d57
-PKG_CAT:=bzcat
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_SOURCE_URL:=https://github.com/westes/flex/releases/download/v$(PKG_VERSION)/
+PKG_HASH:=2c7a412c1640e094cb058d9b2fe39d450186e09574bebb7aa28f783e3799103f
+
+HOST_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/host-build.mk
 
-HOST_LDFLAGS += -static
+HOST_CONFIGURE_ARGS += --disable-shared
 
 define Host/Clean
        -$(MAKE) -C $(HOST_BUILD_DIR) uninstall