tools/mkimage: update to 2023.10
[openwrt/staging/nbd.git] / tools / flex / Makefile
index ca9aa989893640b8422c555c26eea778ca6fef32..86ba5a4415d3a82aaf5e9897736b465cc7e30c42 100644 (file)
@@ -7,6 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=flex
+PKG_CPE_ID:=cpe:/a:flex_project:flex
 PKG_VERSION:=2.6.4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -15,14 +16,26 @@ PKG_HASH:=e87aae032bf07c26f85ac0ed3250998c37621d95f8bd748b31f15b33c45ee995
 
 HOST_FIXUP:=autoreconf
 HOST_BUILD_PARALLEL:=1
-HOST_FIXUP:=autoreconf
 
 include $(INCLUDE_DIR)/host-build.mk
 
 HOST_CONFIGURE_ARGS += --disable-shared
 
+define Host/Compile
+       $(call Host/Compile/Default,SUBDIRS='src tools')
+endef
+
+define Host/Install
+       $(call Host/Compile/Default,install SUBDIRS='src tools')
+       $(LN) flex $(STAGING_DIR_HOST)/bin/lex
+endef
+
+define Host/Uninstall
+       -$(call Host/Compile/Default,uninstall SUBDIRS='src tools')
+endef
+
 define Host/Clean
-       -$(MAKE) -C $(HOST_BUILD_DIR) uninstall
+       rm -f $(STAGING_DIR_HOST)/bin/lex
        $(call Host/Clean/Default)
 endef