tools/cmake: update to 3.28.3
[openwrt/staging/jow.git] / tools / flock / Makefile
index 64a8655b831c8219e846aa2a0e59971648dea642..4e0a45440fa5cd426635be2936a963b0e0dcf2c3 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,9 +7,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME := flock
+PKG_VERSION := 2.18
+PKG_RELEASE := 1
 
 include $(INCLUDE_DIR)/host-build.mk
 
+HOSTCC := $(HOSTCC_NOCACHE)
+HOSTCXX := $(HOSTCXX_NOCACHE)
+
 define Host/Compile
        mkdir -p $(HOST_BUILD_DIR)
        $(HOSTCC) $(HOST_CFLAGS) -o $(HOST_BUILD_DIR)/flock src/flock.c
@@ -19,4 +24,8 @@ define Host/Install
        $(INSTALL_BIN) $(HOST_BUILD_DIR)/flock $(STAGING_DIR_HOST)/bin/
 endef
 
+define Host/Clean
+       rm -f $(STAGING_DIR_HOST)/bin/flock
+endef
+
 $(eval $(call HostBuild))