tools/squashfs4: refresh multiple lzma configuration option patch
[openwrt/staging/jow.git] / tools / gmp / Makefile
index 292d9a5b3aec2ab62fa77373ddb247f6b33022a8..cfd6e30e04ab036d56b5b4704fc6477d21ab8b2d 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009-2012 OpenWrt.org
+# Copyright (C) 2009-2016 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,11 +7,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gmp
-PKG_VERSION:=5.0.5
+PKG_VERSION:=6.2.1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@GNU/gmp/
-PKG_MD5SUM:=8aef50959acec2a1ad41d144ffe0f3b5
+PKG_HASH:=fd4829912cddd12f84181c3451cc752be224643e87fac497b69edddadc49b4f2
+
+HOST_FIXUP:=autoreconf
 
 HOST_BUILD_PARALLEL:=1
 
@@ -22,7 +24,15 @@ unexport CFLAGS
 HOST_CONFIGURE_ARGS += \
        --enable-static \
        --disable-shared \
-       --enable-cxx \
-       --enable-mpbsd
+       --disable-assembly \
+       --enable-cxx
+
+ifeq ($(GNU_HOST_NAME),x86_64-linux-gnux32)
+HOST_CONFIGURE_ARGS += ABI=x32
+endif
+
+define Host/Uninstall
+       -$(call Host/Compile/Default,uninstall)
+endef
 
 $(eval $(call HostBuild))