tools/squashfs4: refresh multiple lzma configuration option patch
[openwrt/staging/jow.git] / tools / gmp / Makefile
index b1976d0cc3db77adb9c3a7d4ed8710c45308abc8..cfd6e30e04ab036d56b5b4704fc6477d21ab8b2d 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009-2013 OpenWrt.org
+# Copyright (C) 2009-2016 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,11 +7,11 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gmp
-PKG_VERSION:=5.1.3
+PKG_VERSION:=6.2.1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@GNU/gmp/
-PKG_MD5SUM:=e5fe367801ff067b923d1e6a126448aa
+PKG_HASH:=fd4829912cddd12f84181c3451cc752be224643e87fac497b69edddadc49b4f2
 
 HOST_FIXUP:=autoreconf
 
@@ -24,11 +24,15 @@ unexport CFLAGS
 HOST_CONFIGURE_ARGS += \
        --enable-static \
        --disable-shared \
-       --enable-cxx \
-       --enable-mpbsd
+       --disable-assembly \
+       --enable-cxx
 
 ifeq ($(GNU_HOST_NAME),x86_64-linux-gnux32)
 HOST_CONFIGURE_ARGS += ABI=x32
 endif
 
+define Host/Uninstall
+       -$(call Host/Compile/Default,uninstall)
+endef
+
 $(eval $(call HostBuild))