qualcommax: ipq807x: use ath11k_patch_mac for SXK80
[openwrt/staging/pepe2k.git] / tools / liblzo / patches / 001-add-cmake-ENABLE-configurables.patch
index 9ab27fc924acdb26709bd59afa2d9137a17bc87b..e0ba41016724804502d4fc35c40b3a8cb2109cfd 100644 (file)
@@ -1,6 +1,6 @@
---- a/CMakeLists.txt   2022-11-28 06:34:39.171209779 -0800
-+++ b/CMakeLists.txt   2022-11-28 06:33:13.368239757 -0800
-@@ -51,8 +51,11 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -51,8 +51,11 @@ endif()
  project(lzo VERSION 2.10 LANGUAGES C)
  
  # configuration options
@@ -14,7 +14,7 @@
  if(NOT ENABLE_STATIC AND NOT ENABLE_SHARED)
      set(ENABLE_STATIC ON)
  endif()
-@@ -127,14 +130,20 @@
+@@ -127,14 +130,20 @@ macro(lzo_add_executable t)
      endif()
  endmacro()
  # main test driver
@@ -35,7 +35,7 @@
  # some boring internal test programs
  if(0)
      lzo_add_executable(align    tests/align.c)
-@@ -144,7 +153,7 @@
+@@ -144,7 +153,7 @@ if(0)
  endif()
  
  # miniLZO
@@ -44,7 +44,7 @@
      add_executable(testmini minilzo/testmini.c minilzo/minilzo.c)
      target_include_directories(testmini PRIVATE "${CMAKE_CURRENT_SOURCE_DIR}/include/lzo") # needed for "lzoconf.h"
  endif()
-@@ -263,8 +272,10 @@
+@@ -263,8 +272,10 @@ add_test(NAME lzotest-03 COMMAND lzotest
  
  if(DEFINED CMAKE_INSTALL_FULL_LIBDIR)
  
@@ -57,7 +57,7 @@
  
  set(f include/lzo/lzo1.h include/lzo/lzo1a.h include/lzo/lzo1b.h
      include/lzo/lzo1c.h include/lzo/lzo1f.h include/lzo/lzo1x.h
-@@ -285,7 +296,7 @@
+@@ -285,7 +296,7 @@ if(ENABLE_SHARED)
      )
  endif()