ramips: fix image generation for mt76x8
[openwrt/staging/chunkeey.git] / tools / libressl / Makefile
index 9338896ee613eb5d17897c3ec91f30d1e6d06308..8894a058e4303adcb5908a4835fe3575a1825c74 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2016 LEDE project
+# Copyright (C) 2016-2017 LEDE project
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,14 +8,16 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libressl
-PKG_VERSION:=2.5.1
-PKG_HASH:=f71ae0a824b78fb1a47ffa23c9c26e9d96c5c9b29234eacedce6b4c7740287cd
+PKG_VERSION:=2.8.1
+PKG_HASH:=334bf7050f1db4087feebb30571ec13d9fa975bf05d6003ce3ab6d7d2452cf42
 PKG_RELEASE:=1
 
+PKG_CPE_ID:=cpe:/a:openbsd:libressl
+
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://mirror.ox.ac.uk/pub/OpenBSD/LibreSSL \
        http://ftp.jaist.ac.jp/pub/OpenBSD/LibreSSL \
-       http://ftp.openbsd.org/pub/OpenBSD/LibreSSL
+       https://ftp.openbsd.org/pub/OpenBSD/LibreSSL
 
 HOST_BUILD_PARALLEL:=1
 
@@ -24,4 +26,8 @@ include $(INCLUDE_DIR)/host-build.mk
 HOST_CONFIGURE_ARGS += --disable-shared
 HOST_CFLAGS += $(FPIC)
 
+ifeq ($(GNU_HOST_NAME),x86_64-linux-gnux32)
+HOST_CONFIGURE_ARGS += --disable-asm
+endif
+
 $(eval $(call HostBuild))