tools/mkimage: update to 2023.04
[openwrt/staging/nbd.git] / tools / libressl / Makefile
index 2b5a33450c829004162ca229b3ba060f5aff3222..8e51e4c54bd4611c4c51f0b8fdcf4542701b7b06 100644 (file)
@@ -8,14 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libressl
-PKG_VERSION:=3.3.1
-PKG_HASH:=a6d331865e0164a13ac85a228e52517f7cf8f8488f2f95f34e7857302f97cfdb
-PKG_RELEASE:=1
+PKG_VERSION:=3.7.1
+PKG_HASH:=98086961a2b8b657ed0fea3056fb2db14294b6bfa193c15a5236a0a35c843ded
 
 PKG_CPE_ID:=cpe:/a:openbsd:libressl
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://mirror.ox.ac.uk/pub/OpenBSD/LibreSSL \
+PKG_SOURCE_URL:=https://mirror.ox.ac.uk/pub/OpenBSD/LibreSSL \
        http://ftp.jaist.ac.jp/pub/OpenBSD/LibreSSL \
        https://ftp.openbsd.org/pub/OpenBSD/LibreSSL
 
@@ -24,11 +23,18 @@ HOST_BUILD_PARALLEL:=1
 include $(INCLUDE_DIR)/host-build.mk
 
 HOSTCC := $(HOSTCC_NOCACHE)
-HOST_CONFIGURE_ARGS += --enable-static --disable-shared --disable-tests
-HOST_CFLAGS += $(FPIC)
 
-ifeq ($(GNU_HOST_NAME),x86_64-linux-gnux32)
-HOST_CONFIGURE_ARGS += --disable-asm
-endif
+HOST_CFLAGS += $(HOST_FPIC)
+
+HOST_CONFIGURE_ARGS += \
+       --enable-static \
+       --disable-shared \
+       --disable-asm \
+       --with-pic \
+       --disable-tests
+
+define Host/Uninstall
+       -$(call Host/Compile/Default,uninstall)
+endef
 
 $(eval $(call HostBuild))