tools/coreutils: rename list of installed programs
[openwrt/staging/nbd.git] / tools / libtool / Makefile
index cc9e8a68fbd86f70b96f8bf307bf5db8a57b2c63..118719147821b9c163ece69e63ea6a6026fba015 100644 (file)
@@ -18,31 +18,42 @@ HOST_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/host-build.mk
 
+export GNULIB_SRCDIR:=$(HOST_GNULIB_SRCDIR)
+
 HOST_CONFIGURE_VARS += \
        lt_cv_sys_dlsearch_path=""
 
+define Host/Bootstrap
+       ( \
+               cd $(HOST_BUILD_DIR); \
+               $(AM_TOOL_PATHS) \
+               ./bootstrap \
+                       --force \
+                       --skip-git \
+                       --skip-po \
+                       --gnulib-srcdir=$(GNULIB_SRCDIR) \
+       )
+endef
+
 define Host/Prepare
        $(call Host/Prepare/Default)
-       (cd $(STAGING_DIR_HOST)/share/aclocal/ && rm -f libtool.m4 ltdl.m4 lt~obsolete.m4 ltoptions.m4 ltsugar.m4 ltversion.m4)
-       $(if $(QUILT),,(cd $(HOST_BUILD_DIR); touch README-release; $(AM_TOOL_PATHS) ./bootstrap --skip-git --skip-po --force))
+       $(call Host/Uninstall)
+       $(if $(QUILT),,$(call Host/Bootstrap))
 endef
 
 define Host/Configure
-       $(if $(QUILT),(cd $(HOST_BUILD_DIR); touch README-release; $(AM_TOOL_PATHS) ./bootstrap --skip-git --skip-po --force))
+       $(if $(QUILT),$(call Host/Bootstrap))
        $(call Host/Configure/Default)
 endef
 
 define Host/Install
-       $(MAKE) -C $(HOST_BUILD_DIR) install
+       $(call Host/Compile/Default,install)
        $(SED) 's,\(hardcode_into_libs\)=yes,\1=no,g' $(STAGING_DIR_HOST)/bin/libtool
 endef
 
 define Host/Uninstall
        -$(call Host/Compile/Default,uninstall)
-endef
-
-define Host/Clean
-       $(call Host/Clean/Default)
+       (cd $(STAGING_DIR_HOST)/share/aclocal/ && rm -f libtool.m4 ltdl.m4 lt~obsolete.m4 ltoptions.m4 ltsugar.m4 ltversion.m4)
 endef
 
 $(eval $(call HostBuild))