tools/mkimage: avoid picking up unrelated /usr/include headers with the same name...
[openwrt/staging/nbd.git] / tools / mkimage / Makefile
index 373d9bebb8cae886d609f7dd736333584a69b776..149aaa6f12aa3bd22f046f4e9d3a9e5a5c2e3ddd 100644 (file)
@@ -18,6 +18,13 @@ HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/u-boot-$(PKG_VERSION)
 
 include $(INCLUDE_DIR)/host-build.mk
 
+define Host/Prepare
+       $(Host/Prepare/Default)
+       rm -f \
+               $(HOST_BUILD_DIR)/include/errno.h \
+               $(HOST_BUILD_DIR)/include/malloc.h
+endef
+
 define Host/Compile
        rm -f $(HOST_BUILD_DIR)/tools/.depend
        touch $(HOST_BUILD_DIR)/include/config.h