tools: add Host/Uninstall where possible
[openwrt/staging/jow.git] / tools / mpc / Makefile
index 27e9a01c4bcc6adc1c2661ad8b51ea4bedee46db..b170043c1a6c1896c0b58e962b30b45e2d56e8b2 100644 (file)
@@ -7,11 +7,11 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mpc
-PKG_VERSION:=1.2.0
+PKG_VERSION:=1.2.1
 
 PKG_SOURCE_URL:=@GNU/mpc/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_HASH:=e90f2d99553a9c19911abdb4305bf8217106a957e3994436428572c8dfe8fda6
+PKG_HASH:=17503d2c395dfcf106b622dc142683c1199431d095367c6aacba6eec30340459
 
 HOST_BUILD_PARALLEL:=1
 
@@ -25,4 +25,8 @@ HOST_CONFIGURE_ARGS += \
        --with-mpfr=$(TOPDIR)/staging_dir/host \
        --with-gmp=$(TOPDIR)/staging_dir/host
 
+define Host/Uninstall
+       -$(call Host/Compile/Default,uninstall)
+endef
+
 $(eval $(call HostBuild))