tools: add Host/Uninstall where possible
[openwrt/staging/dedeckeh.git] / tools / mpc / Makefile
index b2fdb324986cce9fb517c91e40f9fa8c8f994851..b170043c1a6c1896c0b58e962b30b45e2d56e8b2 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009-2012 OpenWrt.org
+# Copyright (C) 2009-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,11 +7,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mpc
-PKG_VERSION:=0.9
+PKG_VERSION:=1.2.1
 
-PKG_SOURCE_URL:=http://www.multiprecision.org/mpc/download/
+PKG_SOURCE_URL:=@GNU/mpc/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_MD5SUM:=0d6acab8d214bd7d1fbbc593e83dd00d
+PKG_HASH:=17503d2c395dfcf106b622dc142683c1199431d095367c6aacba6eec30340459
+
+HOST_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/host-build.mk
 
@@ -23,4 +25,8 @@ HOST_CONFIGURE_ARGS += \
        --with-mpfr=$(TOPDIR)/staging_dir/host \
        --with-gmp=$(TOPDIR)/staging_dir/host
 
+define Host/Uninstall
+       -$(call Host/Compile/Default,uninstall)
+endef
+
 $(eval $(call HostBuild))