tools/7z: Allow building on alpine
[openwrt/staging/nbd.git] / tools / mpfr / Makefile
index 3a2c339d99f202122614d6161de08e351ff44bc5..cdcca5f11aff9fb5162210b369336846672c4f57 100644 (file)
@@ -7,12 +7,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mpfr
-PKG_VERSION:=3.1.4
+PKG_VERSION:=4.2.0
+PKG_CPE_ID:=cpe:/a:mpfr:gnu_mpfr
 
-PKG_SOURCE_URL:=http://www.mpfr.org/mpfr-$(PKG_VERSION) \
-               @GNU/mpfr
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_MD5SUM:=b8a2f6b0e68bef46e53da2ac439e1cf4
+PKG_SOURCE_URL:=@GNU/mpfr http://www.mpfr.org/mpfr-$(PKG_VERSION)
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_HASH:=06a378df13501248c1b2db5aa977a2c8126ae849a9d9b7be2546fb4a9c26d993
 
 HOST_BUILD_PARALLEL:=1
 HOST_FIXUP:=autoreconf
@@ -22,6 +22,11 @@ include $(INCLUDE_DIR)/host-build.mk
 HOST_CONFIGURE_ARGS += \
        --enable-static \
        --disable-shared \
+       --enable-thread-safe \
        --with-gmp=$(STAGING_DIR_HOST)
 
+define Host/Uninstall
+       -$(call Host/Compile/Default,uninstall)
+endef
+
 $(eval $(call HostBuild))