fstools: update to latest git HEAD
[openwrt/staging/yousong.git] / tools / mtools / Makefile
index 994ca8d0d51df5e3b7b86e7bbe8bb76d8281eb2b..13de447780f335ab904e48b0150e9f700d408c8b 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2012 OpenWrt.org
+# Copyright (C) 2012-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,25 +7,32 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mtools
-PKG_VERSION:=4.0.17
+PKG_VERSION:=4.0.18
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@GNU/$(PKG_NAME)
-PKG_MD5SUM:=231741ac95802d03aa32f44edb768171
+PKG_MD5SUM:=17b9f525c1ae3583a478338deb7fbc19
 PKG_CAT:=zcat
 
+HOST_BUILD_PARALLEL:=1
+
 include $(INCLUDE_DIR)/host-build.mk
 
+HOST_CONFIGURE_VARS += \
+       ac_cv_header_iconv_h=no
+
 define Host/Compile
-       $(MAKE) -C $(HOST_BUILD_DIR) mcopy
+       $(MAKE) -C $(HOST_BUILD_DIR) mcopy mmd
 endef
 
 define Host/Install
        $(INSTALL_BIN) $(HOST_BUILD_DIR)/mcopy $(STAGING_DIR_HOST)/bin/
+       $(INSTALL_BIN) $(HOST_BUILD_DIR)/mmd $(STAGING_DIR_HOST)/bin/
 endef
 
 define Host/Clean
        rm -f $(STAGING_DIR_HOST)/bin/mcopy
+       rm -f $(STAGING_DIR_HOST)/bin/mmd
 endef
 
 $(eval $(call HostBuild))