ppp: propagate master peerdns setting to dynamic slave interface
[openwrt/staging/dedeckeh.git] / tools / scons / Makefile
index aadeb289a25952f48e00c35091c48f4e444acd63..a148a5c9c859054e0bc19f613eea9042b1b4d367 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2011 OpenWrt.org
+# Copyright (C) 2011-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,11 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=scons
-PKG_VERSION:=2.1.0
+PKG_VERSION:=2.5.1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=@SF/scons
-PKG_MD5SUM:=47daf989e303a045b76c11236df719df
+PKG_SOURCE_URL:=@SF/scons \
+               http://fossies.org/linux/misc/
+PKG_HASH:=0b25218ae7b46a967db42f2a53721645b3d42874a65f9552ad16ce26d30f51f2
 
 include $(INCLUDE_DIR)/host-build.mk
 
@@ -23,7 +24,12 @@ define Host/Compile
 endef
 
 define Host/Install
-       python $(HOST_BUILD_DIR)/setup.py install --prefix=$(STAGING_DIR_HOST)
+       ./files/pywrap.sh $(HOST_BUILD_DIR)/setup.py install --prefix=$(STAGING_DIR_HOST)
+       rm -f $(STAGING_DIR_HOST)/bin/scons*.py
+       for bin in $(STAGING_DIR_HOST)/bin/scons*; do \
+               mv "$$$$bin" "$$$$bin.py";                \
+               cp ./files/pywrap.sh "$$$$bin";           \
+       done
 endef
 
 $(eval $(call HostBuild))