tools/mold: update to 2.2.0
[openwrt/staging/nbd.git] / tools / xz / Makefile
index 1bccbdb2632710143e46c3302b2caf5a3d526643..757d5ae0e1e1163166d48f88a153232283e1b57d 100644 (file)
@@ -1,4 +1,4 @@
-# 
+#
 # Copyright (C) 2006-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -7,23 +7,34 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=xz
-PKG_VERSION:=5.2.2
+PKG_VERSION:=5.4.4
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@SF/lzmautils \
                http://tukaani.org/xz
-PKG_MD5SUM:=f341b1906ebcdde291dd619399ae944600edc9193619dd0c0110a5f05bfcc89e
+PKG_HASH:=0b6fcde1ac38e90433a2556f500c065950b9bcd2d602006efc334782bdfe6296
+PKG_CPE_ID:=cpe:/a:tukaani:xz
 
 HOST_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/host-build.mk
 
+HOSTCC := $(HOSTCC_NOCACHE)
+HOSTCXX := $(HOSTCXX_NOCACHE)
+
 HOST_CONFIGURE_ARGS += \
        --enable-static=yes \
        --enable-shared=no \
+       --disable-doc \
+       --disable-nls \
+       --with-pic
 
 define Host/Install
        +$(MAKE) $(HOST_JOBS) -C $(HOST_BUILD_DIR) install xzlinks="unxz xzcat"
 endef
 
+define Host/Uninstall
+       -$(call Host/Compile/Default,uninstall)
+endef
+
 $(eval $(call HostBuild))