update_kernel.sh: update it to new kernel hash/version file way
[maintainer-tools.git] / update_kernel.sh
index 0cbdb1d28f0b9466d528ddaa2a7b8ec7aa95a117..2c4bb09469f89bd3cbfebb67d1dd999236dd81d0 100755 (executable)
@@ -155,7 +155,7 @@ if [ "$UPDATE" -eq 1 ]; then
                CHECKSUM=$(./staging_dir/host/bin/mkhash sha256 dl/linux-$PATCHVER.tar.xz)
        fi
 
-       $CMD ./staging_dir/host/bin/sed -i include/kernel-version.mk \
+       $CMD ./staging_dir/host/bin/sed -i include/kernel-${KERNEL} \
                -e "s|LINUX_VERSION-${KERNEL} =.*|LINUX_VERSION-${KERNEL} = ${NEWVER}|" \
                -e "s|LINUX_KERNEL_HASH-${KERNEL}.*|LINUX_KERNEL_HASH-${PATCHVER} = ${CHECKSUM}|"
 fi