[PATCH] update joe package, support for all emulation modes.
[openwrt/svn-archive/archive.git] / utils / at / Makefile
index 37cc19d81845459ddf5d0d6bc4eabe92b3135450..4d7f2455cbd6543f0335a5c86fc39b3b5232eb70 100644 (file)
@@ -1,15 +1,15 @@
-# 
-# Copyright (C) 2008 OpenWrt.org
+#
+# Copyright (C) 2008-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=at
 PKG_VERSION:=3.1.10ubuntu4
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://archive.ubuntu.com/ubuntu/pool/main/a/at
@@ -20,7 +20,9 @@ include $(INCLUDE_DIR)/package.mk
 define Package/at
   SECTION:=utils
   CATEGORY:=Utilities
+  DEPENDS:=+libelf
   TITLE:=Delayed job execution and batch processing
+  URL:=http://packages.ubuntu.com/at
 endef
 
 define Package/at/description
@@ -30,12 +32,18 @@ define Package/at/description
 endef
 
 export SENDMAIL=/bin/true
-EXTRA_CFLAGS:=-DNEED_YYWRAP -I$(PKG_BUILD_DIR)
-CONFIGURE_ARGS+=--with-daemon_username=nobody --with-daemon_groupname=nogroup
+EXTRA_CFLAGS:=-DNEED_YYWRAP -I$(PKG_BUILD_DIR) -I$(STAGING_DIR)/usr/include/libelf \
+       $(TARGET_LDFLAGS)
+
+CONFIGURE_ARGS+=--with-daemon_username=nobody \
+               --with-daemon_groupname=nogroup \
+               --with-jobdir=/var/spool/cron/atjobs \
+               --with-atspool=/var/spool/cron/atspool \
+               --without-pam \
 
 define Package/at/install
        $(INSTALL_DIR) $(1)/usr/bin $(1)/usr/sbin $(1)/etc/init.d/
-       $(INSTALL_BIN) ./files/atd.init $(1)/etc/init.d/
+       $(INSTALL_BIN) ./files/atd.init $(1)/etc/init.d/atd
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/at $(1)/usr/bin
        ln -sf at $(1)/usr/bin/atq
        ln -sf at $(1)/usr/bin/atrm