[packages_10.03.1] fix mtd-utils compilation for brcm-2.4
[openwrt/svn-archive/archive.git] / utils / at / Makefile
index 4d7f2455cbd6543f0335a5c86fc39b3b5232eb70..d0a36766d6cd2b884984375a2e2f751261829769 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008-2009 OpenWrt.org
+# Copyright (C) 2008-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=at
-PKG_VERSION:=3.1.10ubuntu4
-PKG_RELEASE:=2
+PKG_VERSION:=3.1.12
+PKG_RELEASE:=1
 
-PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://archive.ubuntu.com/ubuntu/pool/main/a/at
-PKG_MD5SUM:=64eec8c9e5a6e16e775ee9efe31b8508
+PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.gz
+PKG_SOURCE_URL:=http://ftp.debian.org/debian/pool/main/a/at
+PKG_MD5SUM:=1e67991776148fb319fd77a2e599a765
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -22,24 +22,24 @@ define Package/at
   CATEGORY:=Utilities
   DEPENDS:=+libelf
   TITLE:=Delayed job execution and batch processing
-  URL:=http://packages.ubuntu.com/at
+  URL:=http://packages.debian.org/stable/at
+  MAINTAINER:=Luka Perkov <openwrt@lukaperkov.net>
 endef
 
 define Package/at/description
- At and batch read shell commands from standard input
- storing them as a job to be scheduled for execution in the
- future.
+ At and batch read shell commands from standard input storing them as a job to
+ be scheduled for execution in the future.
 endef
 
 export SENDMAIL=/bin/true
 EXTRA_CFLAGS:=-DNEED_YYWRAP -I$(PKG_BUILD_DIR) -I$(STAGING_DIR)/usr/include/libelf \
        $(TARGET_LDFLAGS)
 
-CONFIGURE_ARGS+=--with-daemon_username=nobody \
+CONFIGURE_ARGS+=--prefix=/usr \
+               --with-daemon_username=nobody \
                --with-daemon_groupname=nogroup \
                --with-jobdir=/var/spool/cron/atjobs \
-               --with-atspool=/var/spool/cron/atspool \
-               --without-pam \
+               --with-atspool=/var/spool/cron/atspool
 
 define Package/at/install
        $(INSTALL_DIR) $(1)/usr/bin $(1)/usr/sbin $(1)/etc/init.d/