[packages] hd-idle: fix parameter processing, its been broken since 3 years and only...
[openwrt/svn-archive/archive.git] / utils / bandwidthd / Makefile
index 62c1963ec156fe5f9b51b7a9d3fec89724d39f71..3ae7d51cdb33d2152b5ba7f328dc8fd70ff848a1 100644 (file)
@@ -1,16 +1,15 @@
 # 
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: Makefile 11018 2008-05-03 12:11:35Z nico $
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bandwidthd
 PKG_VERSION:=2.0.1
-PKG_RELEASE:=1
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=@SF/bandwidthd
@@ -23,7 +22,7 @@ define Package/bandwidthd
   CATEGORY:=Utilities
   TITLE:=Bandwidthd
   URL:=http://bandwidthd.sourceforge.net/
-  DEPENDS:=+libpng +libgd +libpcap
+  DEPENDS:=+libgd +libpcap
 endef
 
 define Package/bandwidthd/daemon
@@ -37,9 +36,10 @@ CONFIGURE_ARGS += \
        ac_cv_file__usr_pkg_include=no \
        ac_cv_file__usr_local_pgsql_lib=no \
        ac_cv_file__usr_local_pgsql_include=no \
+       ac_cv_lib_pq_PQconnectdb=no \
 
-EXTRA_CFLAGS+=-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include
-EXTRA_LDFLAGS+=-L$(STAGING_DIR)/usr/lib -Wl,-rpath-link,$(STAGING_DIR)/usr/lib
+EXTRA_CFLAGS+= $(TARGET_CPPFLAGS)
+EXTRA_LDFLAGS+= $(TARGET_LDFLAGS) -Wl,-rpath-link,$(STAGING_DIR)/usr/lib
 
 define Package/bandwidthd/install
        $(INSTALL_DIR) $(1)/usr/sbin
@@ -50,6 +50,11 @@ define Package/bandwidthd/install
        $(INSTALL_BIN) ./files/bandwidthd.init $(1)/etc/init.d/bandwidthd
        $(INSTALL_DIR) $(1)/www
        $(INSTALL_DATA) $(PKG_BUILD_DIR)/htdocs/legend.gif $(1)/www/
+       $(INSTALL_DATA) $(PKG_BUILD_DIR)/htdocs/logo.gif $(1)/www/
+endef
+
+define Package/bandwidthd/conffiles
+/etc/config/bandwidthd
 endef
 
 $(eval $(call BuildPackage,bandwidthd))