[packages] ipset: fix compilations against Linux v3.3 and newer (ipv6_addr_copy(...
[openwrt/svn-archive/archive.git] / utils / bash-completion / Makefile
index 62c092d0634ce6b3557173d7a15f4fca97d744d7..f5c43920fc34c42b5e2a7f2a9418442f40910656 100644 (file)
@@ -1,16 +1,15 @@
 #
-# Copyright (C) 2009 OpenWrt.org
+# Copyright (C) 2009-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: $
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bash-completion
 PKG_VERSION:=20080705
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://ftp.de.debian.org/debian/pool/main/b/bash-completion/
@@ -26,6 +25,7 @@ define Package/bash-completion
   TITLE:=bash completion scripts
   DEPENDS:=+libncurses +bash
   URL:=http://www.caliban.org/bash/
+  PKGARCH:=all
 endef
 
 define Package/bash-completion/description
@@ -42,8 +42,12 @@ define Build/Compile
 endef
 
 define Package/bash-completion/install
-       $(INSTALL_DIR) $(1)/etc/
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/bash_completion $(1)/etc
+       $(INSTALL_DIR) $(1)/etc
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/bash_completion $(1)/etc/
+endef
+
+define Package/bash-completion/conffiles
+/etc/bash_completion
 endef
 
 $(eval $(call BuildPackage,bash-completion))